The DigiCert Blog

The Latest

OpenSSL Patches “HIGH” Security Vulnerability in 1.1.0

Early this morning, the OpenSSL project team released the security patch 1.1.0e to fix a “HIGH” severity security vulnerability found in OpenSSL 1.1.0. Version 1.0.2 is not affected. However, system admins should patch their 1.1.0 OpenSSL...

Browser Security Icon Updates and SHA-1 Deprecation

Earlier this year, both Google and Mozilla released versions of Chrome and Firefox with changes to their security indicators and updates for the SHA-1 deprecation. Both browsers feel that these changes will simultaneously help users recognize the...

Introducing the Standard User Role in CertCentral

We wanted to let you know about a recent CertCentral updates, which includes a new Standard User role. Now when creating or editing Users in your account, this role is available by default for all CertCentral customers. About Standard Users The...

Page 3 of 3712345...102030...Last »
View More